Ok so I recently bought Crysis 1 on steam along with my new graphics card (a Radeon HD 6770) and no matter what video setting I put it on I could not get it to run at an acceptable frame rate (the highest I got was 40-30 fps).  So after some research I found out that DX10 was set on by default and that it was not optimized very well so I tried turning it off by going into the shortcut properties and adding the line " -dx9" in the launch options.  While it did turn DX10 off the game textures and effects became amazingly glitchy.  So I am currently at a loss as to what to do any suggestions would be much appreciated. 

Also here are the rest of my specs: 

OS: Windows 7 Home Premium

Mobo: Acer Aspire M3470g

CPU: Amd A6-3620

RAM: 4 gb ddr3

PSU: Thermaltake 430w

Storage: 500 gb hard drive